Field Service Cloud Outage
Incident Report for Picksmart Status
Resolved
This incident has been resolved.
Posted Jan 04, 2025 - 09:11 SAST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 03, 2025 - 11:53 SAST
Investigating
We are currently investigating this issue.
Posted Jan 03, 2025 - 10:31 SAST
This incident affected: Field Service Cloud (Field Service Cloud).