iBureau Partial Outage
Incident Report for Picksmart Status
Resolved
This incident has been resolved.
Posted Jun 14, 2021 - 10:40 SAST
Identified
We are currently investigating this issue.
Posted Jun 14, 2021 - 10:18 SAST
This incident affected: iBureau.