iBureau Partial Outage
Incident Report for Picksmart Status
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 10:50 SAST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2021 - 10:32 SAST
Identified
We are currently investigating this issue.
Posted Jun 09, 2021 - 10:30 SAST
This incident affected: iBureau.