Cannot generate Magistrate Packs
Incident Report for Picksmart Status
Resolved
This incident has been resolved.
Posted Jul 18, 2023 - 08:09 SAST
Investigating
The magistrate packs cannot be generated at the moment. We are busy investigating the problem.
Posted Jul 17, 2023 - 10:15 SAST
This incident affected: Legasys.