iDocs - Fault Generating Form 16
Incident Report for Picksmart Status
Resolved
This incident has been resolved.
Posted Oct 06, 2020 - 11:32 SAST
Monitoring
Issue is now fixed and being monitored
Posted Oct 06, 2020 - 11:07 SAST
Identified
Problem generating form 16 pack, currently being fixed.
Posted Oct 06, 2020 - 11:01 SAST