Instability due to emergency server maintenance being done by hosting company Xneelo
Incident Report for Picksmart Status
Resolved
This incident has been resolved.
Posted Jul 30, 2021 - 14:13 SAST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 30, 2021 - 09:08 SAST
Investigating
We are currently investigating this issue.
Posted Jul 30, 2021 - 09:07 SAST
This incident affected: Field Service Cloud (Field Service Cloud) and GPS Cloud, PRI Recruitment.