System down due to Cloudflare Outage

Incident Report for Picksmart Status

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 16:59 SAST

Update

Posted Nov 18, 2025 - 14:22 SAST

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 14:16 SAST
This incident affected: Field Service Cloud (Field Service Cloud) and iBureau, Legasys.